[SOLVED] Mengatasi ‘dkms’ Error saat upgrade/install Virtualbox di Debian

vbox-dkms

Error ini terjadi saat saya hendak upgrade kernel modules virtualbox-4.3:i386 4.3.28-100309~Debian~wheezy <none> ke virtualbox-dkms:all <none> 4.3.18-dfsg-3+deb8u3 di mesin Debian 8. Solusi yang saya lakukan adalah :

  1. rm -r /etc/init.d/vboxdrv
    
  2. apt-get install virtualbox virtualbox-dkms virtualbox-qt
    virtualbox-guest utils virtualbox-guest-additions && apt-get update
  3. Done! 🙂

TAMBAHAN
Beberapa bulan berikutnya saya mengalami error seperti screenshoot di bawah ini saat menjalankan virtualbox :
Screenshot - 04132016 - 10:09:32 AM

Solusi yang saya lakukan yaitu dengan beberapa step berikut :

  1. sudo dpkg-reconfigure virtualbox-dkms
  2. sudo dpkg-reconfigure virtualbox
  3. sudo modprobe vboxdrv
  4. sudo modprobe vboxnetflt
  5. Done!

Sekian, dan semoga membantu.

 

credit: https://packages.debian.org/jessie/virtualbox-dkms
http://stackoverflow.com/questions/13291015/how-to-correct-virtualbox-installation

Advertisements